现在的位置: 首页 > 综合 > 正文

NOJ[1159] Taxi Cab Scheme

2019年02月16日 ⁄ 综合 ⁄ 共 2612字 ⁄ 字号 评论关闭
  • 问题描述
  • Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the
    customers calling to get a cab as soon as possible,there is also a need to schedule all the taxi rides which have been booked in advance.Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all
    of the rides. For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab
    may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest,at least one minute before the new ride's scheduled departure. Note that some rides may end after midnight.
  • 输入
  • On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The
    following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination
    address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.
  • 输出
  • For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.
  • 样例输入
  • 2
    2
    08:00 10 11 9 16
    08:07 9 16 10 11
    2
    08:00 10 11 9 16
    08:06 9 16 10 11
    
  • 样例输出
  • 1
    2
    
  • 提示
  • 来源
  • ZJGSU
  • 操作

用最少的车来搞定所有的预约,最小路径覆盖。关键是建图。

#include<map>
#include<set>
#include<list>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
#include<iterator>

using namespace std;

const int maxn=505;

struct node
{
	int to;
	int next;
}edge[maxn*maxn];
int head[maxn];
int mark[maxn];
bool used[maxn];
int tot;
int m;

struct node2
{
	int t;
	int a,b,c,d;
}p[maxn];

void addedge(int from,int to)
{
	edge[tot].to=to;
	edge[tot].next=head[from];
	head[from]=tot++;
}

bool dfs(int x)
{
	for(int i=head[x];i!=-1;i=edge[i].next)
	{
		if(!used[edge[i].to])
		{
			used[edge[i].to]=1;
			if(mark[edge[i].to]==-1 || dfs(mark[edge[i].to]))
			{
				mark[edge[i].to]=x;
				return true;
			}
		}
	}
	return false;
}

int hungary()
{
	memset(mark,-1,sizeof(mark));
	int ans=0;
	for(int i=1;i<=m;i++)
	{
		memset(used,0,sizeof(used));
		if(dfs(i))
		  ans++;
	}
	return ans;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(head,-1,sizeof(head));
		tot=0;
		scanf("%d",&m);
		int hh,mm;
		for(int i=1;i<=m;i++)
		{
			scanf("%d:%d%d%d%d%d",&hh,&mm,&p[i].a,&p[i].b,&p[i].c,&p[i].d);
			p[i].t=hh*60+mm;
		}
		for(int i=1;i<m;i++)
		  for(int j=i+1;j<=m;j++)
		  {
		  	int t1=p[i].t+abs(p[i].a-p[i].c)+abs(p[i].b-p[i].d)+abs(p[i].c-p[j].a)+abs(p[i].d-p[j].b)+1;
  			 if(t1<=p[j].t)
  			   addedge(i,j);
  		  }
        printf("%d\n",m-hungary());
	}
	return 0;
}

抱歉!评论已关闭.