现在的位置: 首页 > 综合 > 正文

NOJ[1161] Card Game Cheater

2019年02月16日 ⁄ 综合 ⁄ 共 3590字 ⁄ 字号 评论关闭
  • 问题描述
  • Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each
    other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam's cards are numbered from 1 to k from his left, and Eve's cards are numbered 1 to k from her right (so Eve's i:th card is opposite
    Adam's i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}): If Adam's i:th card beats Eve's i:th card, then Adam gets one point. If Eve's i:th card beats Adam's i:th card, then Eve gets one point. A card
    with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace. If the two i:th cards have the same value, then the suit determines who wins: hearts
    beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. This ought to be a game of chance, but lately Eve is
    winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points
    as possible. Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.
  • 输入
  • There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases. Each test case starts with a line with a single positive
    integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described
    by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam's cards are the ten of clubs, the two of hearts, and the Jack of
    diamonds, that could be described by the line TC 2H JD
  • 输出
  • For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.
  • 样例输入
  • 3
    1
    JD
    JH
    2
    5D TC
    4C 5H
    3
    2H 3H 4H
    2D 3D 4D
    
  • 样例输出
  • 1
    1
    2
    
  • 提示
  • 来源
  • ZJGSU

二分图的最大匹配,建边的依据是eve的牌大于adam的牌。

#include<map>
#include<set>
#include<list>
#include<stack>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<string>
#include<iterator>
#include<iostream>
#include<algorithm>
#define inf 0x3f3f3f3f

using namespace std;
const int maxn=50;
struct node
{
    char suit;//花色
    char value;//数值
    int sort_value;
    int sort_suit;
}eve[maxn],adam[maxn];

bool mat[maxn][maxn];
int mark[maxn];
bool used[maxn];
int k;

bool dfs(int x)
{
    for (int i=0;i<k;i++)
    {
        if (mat[x][i] && !used[i])
        {
            used[i]=1;
            if (mark[i]==-1 || dfs(mark[i]))
            {
                mark[i]=x;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int ans=0;
    memset(mark,-1,sizeof(mark));
    for (int i=0;i<k;i++)
    {
        memset(used,0,sizeof(used));
        if (dfs(i))
            ans++;
    }
    return ans;
}

int main()
{
    int t;
    map<char, int>num1;
    map<char, int>num2;
    num1.clear();
    num2.clear();
    num1['2']=2;
    num1['3']=3;
    num1['4']=4;
    num1['5']=5;
    num1['6']=6;
    num1['7']=7;
    num1['8']=8;
    num1['9']=9;
    num1['T']=10;
    num1['J']=11;
    num1['Q']=12;
    num1['K']=13;
    num1['A']=14;
    num2['C']=1;
    num2['D']=2;
    num2['S']=3;
    num2['H']=4;
    scanf("%d",&t);
    while (t--)
    {
        memset(mat,0,sizeof(mat));
        scanf("%d",&k);
        for (int i=0;i<k;i++)
        {
            getchar();
            scanf("%c%c",&adam[i].value,&adam[i].suit);
            adam[i].sort_value=num1[adam[i].value];
            adam[i].sort_suit=num2[adam[i].suit];
        }
        for (int i=0;i<k;i++)
        {
            getchar();
            scanf("%c%c",&eve[i].value,&eve[i].suit);
            eve[i].sort_value=num1[eve[i].value];
            eve[i].sort_suit=num2[eve[i].suit];
        }
        for (int i=0;i<k;i++)
            for (int j=0;j<k;j++)
            {
                if (eve[j].sort_value > adam[i].sort_value)
                    mat[j][i]=1;
                else if (eve[j].sort_value == adam[i].sort_value && eve[j].sort_suit > adam[i].sort_suit)
                    mat[j][i]=1;
            }
        printf("%d\n",hungary());
    }
    return 0;
}

抱歉!评论已关闭.