现在的位置: 首页 > 综合 > 正文

POJ2151—–Check the difficulty of problems

2019年02月17日 ⁄ 综合 ⁄ 共 2590字 ⁄ 字号 评论关闭
Check the difficulty of problems
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5178   Accepted: 2291

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you
calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range
of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石

首先要计算出每一个人做出一定题目的概率
令dp[i][j][k] 表示 第i个人 在前j题里ACk道题的概率
处理完以后,计算每一个人都至少AC一题的概率
在计算出每一个人做出的题目数都在[1, n] 的概率
两者之差就是答案,  它们差的含义就是 每一个人都至少做出一题,但不是所有人的出题数都在[1, n]

/*************************************************************************
    > File Name: POJ2151.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2014年12月24日 星期三 16时53分17秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

double dp[1010][35][35];
double p[1010][35];

int main()
{
	int m, t, n;
	while (~scanf("%d%d%d", &m, &t, &n))
	{
		if (!m && !t && !n)
		{
			break;
		}
		double x = 1.0, y = 1.0;
		memset (dp, 0, sizeof(dp));
		for (int i = 1; i <= t; ++i)
		{
			for (int j = 1; j <= m; ++j)
			{
				scanf("%lf", &p[i][j]);
			}
		}
		for (int i = 1; i <= t; ++i)
		{
			dp[i][0][0] = 1;
			for (int j = 1; j <= m; ++j)
			{
				double tmp = 1;
				for (int k = 1; k <= j; ++k)
				{
					tmp *= (1 - p[i][k]);
				}
				dp[i][j][0] = tmp;
				for (int k = 1; k <= j; ++k)
				{
					dp[i][j][k] = dp[i][j - 1][k - 1] * p[i][j] + dp[i][j - 1][k] * (1 - p[i][j]);
				}
			}
		}
		for (int i = 1; i <= t; ++i)
		{
			double tmp = 0;
			for (int j = 1; j <= m; ++j)
			{
				tmp += dp[i][m][j];
			}
			x *= tmp;//每一个队伍至少AC一道题的概率
		}
		for (int i = 1; i <= t; ++i)
		{
			double tmp = 0;
			for (int j = 1; j < n; ++j)
			{
				tmp += dp[i][m][j];
			}
			y *= tmp;
		}
		printf("%.3f\n", x - y);
	}
	return 0;
}

抱歉!评论已关闭.