现在的位置: 首页 > 综合 > 正文

hdu1151——Air Raid

2019年02月17日 ⁄ 综合 ⁄ 共 2992字 ⁄ 字号 评论关闭

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3433    Accepted Submission(s): 2265

Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection
i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper
lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

 

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets
in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk
<= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

 

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections
in the town.
 

Sample Input
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
 

Sample Output
2 1
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1281 1507 1528 1498 1533

每个伞兵要走一条边,用最少的伞兵走光所有的点,那么显然是最小路径覆盖了, 一条路只可能有一个伞兵有,所以路最少->人最少

#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 222;
struct node 
{
    int next;
    int to;
}edge[2500];

int head[N];
int mark[N];
bool vis[N];
int tot, n, m, k;

void addedge(int from, int to)
{
    edge[tot].to = to;
    edge[tot].next = head[from];
    head[from] = tot++;
}

bool dfs(int u)
{
    for (int i = head[u]; ~i; i = edge[i].next)
    {
        int v = edge[i].to;
        if (!vis[v])
        {
            vis[v] = 1;
            if (mark[v] == -1 || dfs(mark[v]))
            {
                mark[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    memset (mark, -1, sizeof(mark) );
    int ans = 0;
    for (int i = 1; i <= n; i++)
    {
        memset (vis, 0, sizeof(vis) );
        if (dfs(i))
        {
            ans++;
        }
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &n, &m);
        memset (head, -1, sizeof(head) );
        tot = 0;
        int u, v;
        for (int i = 0; i < m; i++)
        {
            scanf("%d%d", &u, &v);
            addedge(u, v);
        }
        printf("%d\n", n - hungary());
    }
    return 0;
}

抱歉!评论已关闭.