现在的位置: 首页 > 综合 > 正文

hdu1150——Machine Schedule

2019年02月17日 ⁄ 综合 ⁄ 共 2765字 ⁄ 字号 评论关闭

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5965    Accepted Submission(s): 2999

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type
of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to
a suitable machine, please write a program to minimize the times of restarting machines.

 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs,
each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
3
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1151 1281 1507 1528 1498

最小点覆盖,画一下图就知道了,对(a,x,y),从x -> y连一条边

如果有连到同一个y的,那么这个y就关联了多个任务,所以选择它是比较合理的,所以选取最少的点来关联所有边,就是我们要求的答案了

#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int N = 222;
struct node 
{
	int next;
	int to;
}edge[2500];

int head[N];
int mark[N];
bool vis[N];
int tot, n, m, k;

void addedge(int from, int to)
{
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

bool dfs(int u)
{
	for (int i = head[u]; ~i; i = edge[i].next)
	{
		int v = edge[i].to;
		if (!vis[v])
		{
			vis[v] = 1;
			if (mark[v] == -1 || dfs(mark[v]))
			{
				mark[v] = u;
				return true;
			}
		}
	}
	return false;
}

int hungary()
{
	memset (mark, -1, sizeof(mark) );
	int ans = 0;
	for (int i = 1; i <= n; i++)
	{
		memset (vis, 0, sizeof(vis) );
		if (dfs(i))
		{
			ans++;
		}
	}
	return ans;
}

int main()
{
	while (~scanf("%d", &n), n)
	{
		scanf("%d%d", &m, &k);
		memset (head, -1, sizeof(head) );
		tot = 0;
		int x, u, v;
		for (int i = 0; i < k; i++)
		{
			scanf("%d%d%d", &x, &u, &v);
			addedge(u, v);
		}
		printf("%d\n", hungary());
	}
	return 0;
}
 

抱歉!评论已关闭.