现在的位置: 首页 > 综合 > 正文

hdu1075——What Are You Talking About

2019年02月18日 ⁄ 综合 ⁄ 共 2495字 ⁄ 字号 评论关闭
Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book
into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines
follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book
part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate
it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated.
A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 

Author
Ignatius.L
 

Recommend

字典树裸题,算是复习了 -.-

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

struct dic
{
	dic *next[28];
	char str[15];
	int num;
	dic():num(0){memset(next,0,sizeof(next));}
};

dic *root;
char xx[3011];

void insert(char *s1,char *s2)
{
	int len=strlen(s1);
	dic *p=root;
	for(int i=0;i<len;i++)
	{
		if(p->next[s1[i]-'a']==0)
		{
			dic *q=new dic;
			p->next[s1[i]-'a']=q;		
		}
		p=p->next[s1[i]-'a'];
	}
	p->num=1;
	strcpy(p->str,s2);
}

char *find(char *str)
{
	int len=strlen(str),Id;
	dic *p=root;
	for(int i=0;i<len;i++)
	{
		Id=str[i]-'a';
		p=p->next[Id];
		if(p==0)
			return NULL;
	}
	if(p->num==1)
		return p->str;
	return NULL;
}

int main()
{
	char s[15],e[15];
	root=new dic;
	scanf("%s",s);
	while(scanf("%s",s) && strcmp(s,"END"))
	{
		scanf("%s",e);
		insert(e,s);
	}
	scanf("%s",s);
	getchar();
	while(gets(xx)&& strcmp("END",xx))
	{
		int len=strlen(xx);
		int j=0;
		for(int i=0;i<len;i++)
		{
			while(xx[i]>='a' && xx[i]<='z')
			{
				e[j++]=xx[i++];
			}
			e[j]='\0';
			char *t=find(e);
			if(t!=NULL)
				printf("%s",t);
			else
				printf("%s",e);
			printf("%c",xx[i]);
			j=0;
		}
		printf("\n");
	}
	return 0;
}

抱歉!评论已关闭.