现在的位置: 首页 > 综合 > 正文

hdu2852——KiKi’s K-Number

2019年02月18日 ⁄ 综合 ⁄ 共 2102字 ⁄ 字号 评论关闭
Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?

 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.

 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 

Sample Input
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
No Elment! 6 Not Find! 2 2 4 Not Find!
 

Source
 

Recommend

树状数组+二分
PS: 树状数组果然吊,我喜欢这种灵活的不能轻易掌握的东西,正如男人喜欢掌握不了的女人

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int tree[100010];
int num[100010];
inline int lowbit(int x)
{
	return x&(-x);
}

void add(int x,int val)
{
	for(int i=x;i<=100010;i+=lowbit(i))
		tree[i]+=val;
}

inline int sum(int x)
{
	int ans=0;
	for(int i=x;i;i-=lowbit(i))
		ans+=tree[i];
	return ans;
}

int main()
{
	int m;
	while(~scanf("%d",&m))
	{
		int q,a,k,mid,l,r,e;
		memset(tree,0,sizeof(tree));
		memset(num,0,sizeof(num));
		while(m--)
		{
			scanf("%d",&q);
			if(q==0)
			{
				scanf("%d",&e);
				add(e,1);
				num[e]++;
			}
			else if(q==1)
			{
				scanf("%d",&e);
				if(num[e]==0)
					printf("No Elment!\n");
				else
				{
					num[e]--;
					add(e,-1);
				}
			}
			else
			{
				scanf("%d%d",&a,&k);
				l=a;
				r=100010;
				int ans=100010,low=sum(a),MID;
				while(l<=r)
				{
					mid=(l+r)>>1;
					MID=sum(mid);
					if(MID-low>=k)
					{
						r=mid-1;
						ans=min(ans,mid);
					}
					else
						l=mid+1;
				}
				if(ans==100010)
					printf("Not Find!\n");
				else
					printf("%d\n",ans);
			}
		}
	}
	return 0;
}

抱歉!评论已关闭.