现在的位置: 首页 > 综合 > 正文

hdu2838——Cow Sorting

2019年02月18日 ⁄ 综合 ⁄ 共 1815字 ⁄ 字号 评论关闭
Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would
like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units
of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.

 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
3 2 3 1
 

Sample Output
7
Hint
Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
 

Source
 

Recommend

求所有逆序对的和,开两个树状数组,一个用来记录比当前点小的点的个数,另一个记录比当前点小的点的个数的和

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

__int64 tree[100010];
__int64 c[100010];
__int64 val[100010];

int n;
__int64 ans1=0,ans2=0;
inline int lowbit(int x)
{
	return x&(-x);
}

void add1(int x,int val)
{
	for(int i=x;i<=100010;i+=lowbit(i))
		tree[i]+=val;	
}

void add2(int x,int val)
{
	for(int i=x;i<=100010;i+=lowbit(i))
		c[i]++;	
}

void sum(int x)
{
	for(int i=x;i;i-=lowbit(i))
	{
		ans1+=tree[i];
		ans2+=c[i];
	}
}


int main()
{
	while(~scanf("%d",&n))
	{
		__int64 ans=0,t=0;
		memset(tree,0,sizeof(tree));
		memset(c,0,sizeof(c));
		for(int i=1;i<=n;i++)
			scanf("%d",&val[i]);
		for(int i=1;i<=n;i++)
		{
			ans1=ans2=0;
			add1(val[i],val[i]);
			add2(val[i],1);
			t+=val[i];
			sum(val[i]);
			ans+=t-ans1+(i-ans2)*val[i];
		}
		printf("%I64d\n",ans);
	}
	return 0;
}

抱歉!评论已关闭.