现在的位置: 首页 > 综合 > 正文

hdu2425——Hiking Trip

2019年02月19日 ⁄ 综合 ⁄ 共 3360字 ⁄ 字号 评论关闭

Hiking Trip

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1291    Accepted Submission(s): 568

Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired
and so needs to find the path that will bring him to the destination with the least amount of time. Can you help him?
You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or
path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.
Given Green's current position and his destination, please determine the best path for him.
 

Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, VP, VS,
VT (1 <= VP <= 100, 1 <= VS <= 100, 1 <= VT <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines
contains exactly C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, SR, SC, TR, TC, (0 <=
SR < R, 0 <= SC < C, 0 <= TR < R, 0 <= TC < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.
There is a blank line after each test case. Input ends with End-of-File.
 

Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 

Sample Input
4 6 1 2 10 T...TT TTT### TT.@#T ..###@ 0 1 3 0 4 6 1 2 2 T...TT TTT### TT.@#T ..###@ 0 1 3 0 2 2 5 1 3 T@ @. 0 0 1 1
 

Sample Output
Case 1: 14 Case 2: 8 Case 3: -1
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2426 2421 2424 2418 2423

水题, BFS +优先队列

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

char mat[22][22];
bool vis[22][22];
int r, c;

int dir[4][2] = { {1, 0}, {-1, 0}, {0, 1}, {0, -1} };
int vp, vs, vt;

struct node
{
	int x, y;
	int t;
	friend bool operator < (node a, node b)
	{
		return a.t > b.t;
	}
};

bool is_ok(node temp)
{
	if(temp.x < 0 || temp.x >= r || temp.y < 0 || temp.y >= c || mat[temp.x][temp.y] == '@')
		return false;
	return true;
}

void bfs(int sx, int sy, int ex, int ey)
{
	priority_queue<node>qu;
	memset( vis, 0, sizeof(vis) );
	while( !qu.empty() )
		qu.pop();
	node temp1, temp2;
	int ans;
	bool flag = false;
	temp1.x = sx;
	temp1.y = sy;
	temp1.t = 0;
	vis[temp1.x][temp1.y] = 1;
	qu.push(temp1);
	while( !qu.empty() )
	{
		temp1 = qu.top();
		qu.pop();
		if(temp1.x == ex && temp1.y == ey)
		{
			ans = temp1.t;
			flag = true;
			break;
		}
		for(int i = 0;i < 4; i ++)
		{
			temp2.x = temp1.x + dir[i][0];
			temp2.y = temp1.y + dir[i][1];
			temp2.t = temp1.t;
			if( !is_ok(temp2) )
				continue;
			if( vis[temp2.x][temp2.y] )
				continue;
			vis[temp2.x][temp2.y] = 1;
			if( mat[temp2.x][temp2.y] == '#')
				temp2.t += vp;
			else if( mat[temp2.x][temp2.y] == '.')
				temp2.t += vs;
			else
				temp2.t += vt;
			qu.push(temp2);
		}
	}
	if(flag)
		printf("%d\n",ans);
	else
		printf("-1\n");
}

int main()
{
	int icase = 1;
	int sx, sy, ex, ey;
	while(~scanf("%d%d", &r, &c))
	{
		scanf("%d%d%d", &vp, &vs, &vt);
		for(int i = 0; i < r; i ++)
			scanf("%s", mat[i]);
		scanf("%d%d%d%d", &sx, &sy, &ex, &ey);
		printf("Case %d: ", icase ++);
		if( mat[ex][ey] == '@')
			printf("-1\n");
		else
			bfs(sx, sy, ex, ey);
	}
	return 0;
}

抱歉!评论已关闭.