现在的位置: 首页 > 综合 > 正文

POJ1157——LITTLE SHOP OF FLOWERS

2019年02月19日 ⁄ 综合 ⁄ 共 3046字 ⁄ 字号 评论关闭
LITTLE SHOP OF FLOWERS
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18481   Accepted: 8512

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered
consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have
a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1),
a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be
in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has
an aesthetic value of 0.

 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have
to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.
  • The following F lines: Each of these lines contains V integers, so that
    Aij is given as the jth number on the (i+1)st line of the input file.

  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source

IOI 1999

给出f朵花,v个花瓶,要把花都插到花瓶里去,而且花的顺序不能改变,编号小的在左边,每朵花放到花瓶里都会有一定的价值,问如何放才能产生最大的价值

我们设dp[i][j]表示处理到第i朵花,然后把第i朵花放到第j个花瓶里时所能获得的最大价值;
显然 dp[i][j]  = max(dp[i - 1][k]) + val[i][j],其中k< j  val[i][j]表示把第i朵花放到第j个花瓶里产生的价值
一开始初始化错了,然后WA了2次,不过初始化完全以后就AC了

#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
  
using namespace std;

const int inf = -0x3f3f3f3f;
int dp[105][105];
int mat[105][105];

int main()
{
	int f, v;
	while (~scanf("%d%d", &f, &v))
	{
		memset (dp, inf, sizeof(dp));
		for (int i = 1; i <= f; ++i)
		{
			for (int j = 1; j <= v; ++j)
			{
				scanf("%d", &mat[i][j]);
			}
		}
		for (int i = 0; i <= v; ++i)
		{
			dp[0][i] = 0;
		}
		dp[1][1] = mat[1][1];
		for (int i = 1; i <= f; ++i)
		{
			for (int j = 1; j <= v; ++j)
			{
				for (int k = 1; k < j; ++k)
				{
					dp[i][j] = max(dp[i][j], dp[i - 1][k] + mat[i][j]);
				}
			}
		}
		int ans = inf;
		for (int i = 1; i <= v; ++i)
		{
			ans = max(ans, dp[f][i]);
		}
		printf("%d\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.