现在的位置: 首页 > 综合 > 正文

POJ1159 Palindrome

2019年02月27日 ⁄ 综合 ⁄ 共 1457字 ⁄ 字号 评论关闭
Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 44449   Accepted: 15147

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

求一个字符串填多少字符可以变成回文,其实就是一道lcs求最长公共子序列的问题,求字符串a与它反向字符串的最长公共子序列长度,再用n减去它
这里开int的话会超内存,所以就short啦,因为没有负数,就开了unsigned,让它范围大一点

#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
using namespace std;
unsigned short f[5001][5001];
int main()
{
    int n;
    string a,b;
    while(cin>>n)
    {
        cin>>a;
        b=a;
        reverse(b.begin(),b.end());
        for(int i=0;i<=n;i++)
        {
            f[0][i]=0;
            f[i][0]=0;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[i-1]==b[j-1])
                {
                    f[i][j]=f[i-1][j-1]+1;
                }
                else f[i][j]=max(f[i-1][j],f[i][j-1]);
            }
        }
        cout<<n-f[n][n]<<endl;
   }
    return 0;
}

抱歉!评论已关闭.