现在的位置: 首页 > 综合 > 正文

POJ2007 Scrambled Polygon

2019年02月27日 ⁄ 综合 ⁄ 共 2996字 ⁄ 字号 评论关闭
Scrambled Polygon
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5515   Accepted: 2626

Description

A closed polygon is a figure bounded by a finite number of line segments. The intersections of the bounding line segments are called the vertices of the polygon. When one starts at any vertex of a closed polygon and traverses each bounding line segment exactly
once, one comes back to the starting vertex. 

A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have
any "dents".) 



The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem. 

The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0). 

To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with
(0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point. 

 

Input

The input lists the vertices of a closed convex polygon in the plane. The number of lines in the input will be at least three but no more than 50. Each line contains the x and y coordinates of one vertex. Each x and y coordinate is an integer in the range -999..999.
The vertex on the first line of the input file will be the origin, i.e., x = 0 and y = 0. Otherwise, the vertices may be in a scrambled order. Except for the origin, no vertex will be on the x-axis or the y-axis. No three vertices are colinear.

Output

The output lists the vertices of the given polygon, one vertex per line. Each vertex from the input appears exactly once in the output. The origin (0,0) is the vertex on the first line of the output. The order of vertices in the output will determine a trip
taken along the polygon's border, in the counterclockwise direction. The output format for each vertex is (x,y) as shown below.

Sample Input

0 0
70 -50
60 30
-30 -50
80 20
50 -60
90 -20
-30 -40
-10 -60
90 10

Sample Output

(0,0)
(-30,-40)
(-30,-50)
(-10,-60)
(50,-60)
(70,-50)
(90,-20)
(90,10)
(80,20)
(60,30)

Source

这是一道比较水的凸包问题,第一个点就是起始点,连排序都省了,水过啊

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int num,index;
struct node
{
    double x,y;
    bool v;
}p[51];//这个can函数,是这个凸包问题的核心啊,就是判断是不是凸包的下一个点
int can(int a,int b)
{
    if(a==b||p[b].v==1)return 0;
    for(int i=0;i<num;i++)
    {
        if(i==a||i==b)continue;
        if((p[b].x-p[a].x)*(p[i].y-p[a].y)-(p[b].y-p[a].y)*(p[i].x-p[a].x)<=0)return 0;
    }
    if(b==0)return 2;
    else return 1;
}
int main()
{
    num=0;
    while(scanf("%lf%lf",&p[num].x,&p[num].y)!=EOF)
    {
        p[num].v=0;
        num++;
    }
    index=0;
    cout<<"("<<p[0].x<<","<<p[0].y<<")"<<endl;
    while(1)
    {
        for(int i=0;i<num;i++)
        {
            int r=can(index,i);
            if(r==0)continue;
            else if(r==1)
            {
                index=i;
                p[i].v=1;
                cout<<"("<<p[i].x<<","<<p[i].y<<")"<<endl;
                break;
            }
            else if(r==2)return 0;
        }
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.