现在的位置: 首页 > 综合 > 正文

POJ2253 Frogger

2019年02月27日 ⁄ 综合 ⁄ 共 2539字 ⁄ 字号 评论关闭
Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18645   Accepted: 6063

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

先求出最小生成树,再求出点1到点2的路径中最长的一段,被坑了好久啊
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double map[201][201];
double dis[201];
int fa[201];
double s;
double go(int x)
{
    if(fa[x]==x)return 0;
    int r=fa[x];
    if(s<dis[x])s=dis[x];
    go(fa[x]);
    return 0;
}
int main()
{
    int n;
    int num=1;
    while(cin>>n)
    {
        s=0;
        if(n==0)break;
        double a[201],b[201];
        for(int i=1;i<=n;i++)scanf("%lf%lf",&a[i],&b[i]);
        for(int x=1;x<n;x++)
        {
            for(int y=x+1;y<=n;y++)
            {
                map[x][y]=sqrt((a[x]-a[y])*(a[x]-a[y])+(b[x]-b[y])*(b[x]-b[y]));
                map[y][x]=map[x][y];
            }
        }
        bool used[201];
        memset(used,0,sizeof(used));
        used[1]=1;
        for(int i=1;i<=n;i++)
        {
            dis[i]=map[1][i];
            fa[i]=1;
        }
        for(int i=1;i<n;i++)
        {
            double mi=1001;
            int index=0;
            for(int x=1;x<=n;x++)
            {
                if(used[x]==0&&dis[x]<mi)
                {
                    mi=dis[x];
                    index=x;
                }
            }
            if(index)
            {
                used[index]=1;
                if(index==2)break;
                for(int y=1;y<=n;y++)
                {
                    if(used[y]==0&&dis[y]>map[index][y])
                    {
                        dis[y]=map[index][y];
                        fa[y]=index;
                    }
                }
            }
        }
        go(2);
        cout<<"Scenario #"<<num<<endl<<"Frog Distance = ";
        printf("%.3f\n\n",s);
        num++;
    }
    return 0;
}

抱歉!评论已关闭.