现在的位置: 首页 > 算法 > 正文

poj3083 各种搜

2019年02月28日 算法 ⁄ 共 5536字 ⁄ 字号 评论关闭
Children of the Candy Corn
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7746   Accepted: 3357

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. 

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom
the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.) 

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding
visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze
layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'. 

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also
be separated by at least one wall ('#'). 

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one
square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

Source

dfs和bfs的综合体,记得以前就做,一直没a,今天终于a了,怨念。。。原来以前代码深搜有点顺序问题,最短距离没用bfs,各种悲剧。。。。。。。
代码有点长,长就长吧,。。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char a[100][100];
bool v[100][100];
int m,n,ll,lr,mi;
struct node
{
    int xx,yy,dep;
};
int zuo(int x,int y,int z)
{
    ll++;
    if(a[x][y]=='E')return 0;
    if(z==1)
    {
        if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))zuo(x,y-1,4);
        else if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))zuo(x-1,y,1);
        else if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))zuo(x,y+1,2);
        else if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))zuo(x+1,y,3);
    }
    else if(z==2)
    {
        if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))zuo(x-1,y,1);
        else if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))zuo(x,y+1,2);
        else if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))zuo(x+1,y,3);
        else if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))zuo(x,y-1,4);
    }
    else if(z==3)
    {
        if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))zuo(x,y+1,2);
        else if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))zuo(x+1,y,3);
        else if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))zuo(x,y-1,4);
        else if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))zuo(x-1,y,1);
    }
    else if(z==4)
    {
        if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))zuo(x+1,y,3);
        else if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))zuo(x,y-1,4);
        else if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))zuo(x-1,y,1);
        else if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))zuo(x,y+1,2);
    }
    return 0;
}
int you(int x,int y,int z)
{
    lr++;
    if(a[x][y]=='E')return 0;
    if(z==1)
    {
        if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))you(x,y+1,2);
        else if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))you(x-1,y,1);
        else if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))you(x,y-1,4);
        else if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))you(x+1,y,3);
    }
    else if(z==2)
    {
        if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))you(x+1,y,3);
        else if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))you(x,y+1,2);
        else if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))you(x-1,y,1);
        else if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))you(x,y-1,4);
    }
    else if(z==3)
    {
        if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))you(x,y-1,4);
        else if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))you(x+1,y,3);
        else if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))you(x,y+1,2);
        else if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))you(x-1,y,1);
    }
    else if(z==4)
    {
        if(x-1>=0&&(a[x-1][y]=='.'||a[x-1][y]=='E'))you(x-1,y,1);
        else if(y-1>=0&&(a[x][y-1]=='.'||a[x][y-1]=='E'))you(x,y-1,4);
        else if(x+1<m&&(a[x+1][y]=='.'||a[x+1][y]=='E'))you(x+1,y,3);
        else if(y+1<n&&(a[x][y+1]=='.'||a[x][y+1]=='E'))you(x,y+1,2);
    }
    return 0;
}
int go(int x,int y)
{
    memset(v,0,sizeof(v));
    queue<node>p;
    v[x][y]=1;
    node temp;
    temp.xx=x;
    temp.yy=y;
    temp.dep=1;
    p.push(temp);
    while(!p.empty())
    {
        node q=p.front();
        p.pop();
        if(q.xx-1>=0&&v[q.xx-1][q.yy]==0&&a[q.xx-1][q.yy]!='#')
        {
            v[q.xx-1][q.yy]=1;
            if(a[q.xx-1][q.yy]=='E')
            {
                mi=q.dep+1;
                return 0;
            }
            else
            {
                temp.xx=q.xx-1;
                temp.yy=q.yy;
                temp.dep=q.dep+1;
                p.push(temp);
            }
        }
        if(q.xx+1<m&&v[q.xx+1][q.yy]==0&&a[q.xx+1][q.yy]!='#')
        {
            v[q.xx+1][q.yy]=1;
            if(a[q.xx+1][q.yy]=='E')
            {
                mi=q.dep+1;
                return 0;
            }
            else
            {
                temp.xx=q.xx+1;
                temp.yy=q.yy;
                temp.dep=q.dep+1;
                p.push(temp);
            }
        }
        if(q.yy+1<n&&v[q.xx][q.yy+1]==0&&a[q.xx][q.yy+1]!='#')
        {
            v[q.xx][q.yy+1]=1;
            if(a[q.xx][q.yy+1]=='E')
            {
                mi=q.dep+1;
                return 0;
            }
            else
            {
                temp.xx=q.xx;
                temp.yy=q.yy+1;
                temp.dep=q.dep+1;
                p.push(temp);
            }
        }
        if(q.yy-1>=0&&v[q.xx][q.yy+1]==0&&a[q.xx][q.yy+1]!='#')
        {
            v[q.xx][q.yy-1]=1;
            if(a[q.xx][q.yy-1]=='E')
            {
                mi=q.dep-1;
                return 0;
            }
            else
            {
                temp.xx=q.xx;
                temp.yy=q.yy-1;
                temp.dep=q.dep+1;
                p.push(temp);
            }
        }
    }
    return 0;
}
int main()
{
    int t,sx,sy;
    scanf("%d",&t);
    while(t--)
    {
        int ji=0;
        memset(v,0,sizeof(v));
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            scanf("%s",&a[i]);
            if(ji==0)
            {
                for(int j=0;j<n;j++)
                {
                    if(a[i][j]=='S')
                    {
                        ji=1;
                        sx=i;
                        sy=j;
                    }
                }
            }
        }
        ll=0;
        lr=0;
        zuo(sx,sy,1);
        you(sx,sy,1);
        mi=lr;
        go(sx,sy);
        cout<<ll<<" "<<lr<<" "<<mi<<endl;
    }
    return 0;
}

抱歉!评论已关闭.