现在的位置: 首页 > 算法 > 正文

poj2236 并查集

2019年02月28日 算法 ⁄ 共 2421字 ⁄ 字号 评论关闭
Wireless Network
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 13286   Accepted: 5618

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by
one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the
communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers
xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source

题目水啊,还是wa了2次,因为FAIL写成FALL了。。。。郁闷啊
这道题大意:
n个电脑,坏了,修他们,然后d米内的两台可以相互联通,这种联系可以传递的,就是这样。
输入是n台电脑,d为能连接距离
然后是n行代表每台坐标;
接下来是EOF的输入
O为修好一台电脑,后面跟编号;
S为测试两台电脑是否能连接,后面两个数字代表编号
so easy,自己看着办吧
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int n,d,x[1005],y[1005],a,b,f[1005];
char o;
bool v[1005];
bool dis(int i,int j)
{
    if((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])<=d*d)return true;
    else return false;
}
int find(int i)
{
    if(f[i]==i)return i;
    else return find(f[i]);
}
void un(int i,int j)
{
    i=find(i);
    j=find(j);
    f[i]=j;
}
int main()
{
    scanf("%d%d",&n,&d);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&x[i],&y[i]);
        v[i]=0;
        f[i]=i;
    }
    while(scanf("%s",&o)!=EOF)
    {
        if(o=='O')
        {
            scanf("%d",&a);
            v[a]=1;
            for(int i=1;i<=n;i++)
            {
                if(v[i]==1&&dis(a,i))un(a,i);
            }
        }
        else
        {
            scanf("%d%d",&a,&b);
            if(find(a)==find(b))cout<<"SUCCESS"<<endl;
            else cout<<"FAIL"<<endl;
        }
    }
    return 0;
}

抱歉!评论已关闭.