现在的位置: 首页 > 算法 > 正文

poj2492

2019年02月28日 算法 ⁄ 共 2028字 ⁄ 字号 评论关闭
A Bug's Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 23202   Accepted: 7553

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany
这道属于并查集啊,种类并查集,通过设一个关系数组,标记它的类别,并在找父亲的时候不断更新关系
#include<iostream>
#include<cstdio>
using namespace std;
int n,m,f[2001],r[2001],ans,num;
int a,b;
int find(int i)
{
    if(f[i]==i)return i;
    int t=f[i];
    f[i]=find(f[i]);
    r[i]=(r[i]+r[t]+1)%2;
    return f[i];
}
void un(int a,int b)
{
    int x=find(a);
    int y=find(b);
    f[x]=y;
    r[x]=(r[b]-r[a])%2;
}
int main()
{
    num=1;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            f[i]=i;
            r[i]=1;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            if(find(a)==find(b))
            {
                if(r[a]==r[b])ans=1;
            }
            else
            {
                un(a,b);
            }
        }
        if(ans)cout<<"Scenario #"<<num++<<":"<<endl<<"Suspicious bugs found!"<<endl;
        else cout<<"Scenario #"<<num++<<":"<<endl<<"No suspicious bugs found!"<<endl;
        cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.