现在的位置: 首页 > 算法 > 正文

poj3273 二分枚举

2019年02月28日 算法 ⁄ 共 1596字 ⁄ 字号 评论关闭
Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9834   Accepted: 4022

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤
moneyi ≤ 10,000) that he will need to spend each day over the next
N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤
M
N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and
M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the
ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a
larger minimum monthly limit.

Source

昨天astar上出现了这种题,几乎和这个一模一样,我做挫了,没搞出来。
在印象中二分一直是查找,对于枚举开始一头雾水啊,挫爆了。
哎。。。。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int n,m,a[100005],ma,sum,low,mid,high,num;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ma=0;
        sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            if(ma<a[i])ma=a[i];
            sum+=a[i];

        }
        high=sum;
        low=ma;
        while(low<high)
        {
            mid=(low+high)/2;
            sum=0;
            num=1;
            for(int i=0;i<n;i++)
            {
                if(sum+a[i]<=mid)
                {
                    sum+=a[i];
                }
                else
                {
                    num++;
                    sum=a[i];
                }
            }
            if(num>m)low=mid+1;
            else high=mid;
        }
        cout<<low<<endl;
    }
    return 0;
}

抱歉!评论已关闭.