现在的位置: 首页 > 算法 > 正文

poj 1745

2019年02月28日 算法 ⁄ 共 1702字 ⁄ 字号 评论关闭
Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9199   Accepted: 3197

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are
eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

Source

给你n个数,第一个默认加,后面通过+或-计算问能否被k整除。
第一感觉想列出所有结果,一想复杂度O(2^n),果断放弃这想法。
然后就是dp啦,其实只要记录每次的余数,看最后一次余数为0是否可能,这样复杂度大大降低,O(n*k),最多1000000次计算嘛
然而这里记录余数要注意,要把负的改成正的,我就这里没注意wa了几次
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int z(int i)
{
    return i>0?i:-i;
}
int main()
{
    int n,k,a;
    bool f[10005][105];
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(f,0,sizeof(f));
        scanf("%d",&a);
        f[1][z(a%k)]=1;
        for(int i=2; i<=n; i++)
        {
            scanf("%d",&a);
            for(int j=0; j<k; j++)
            {
                if(f[i-1][j])
                {
                    f[i][z((j+a)%k)]=1;
                    f[i][z((j-a)%k)]=1;
                }
            }
        }
        if(f[n][0])cout<<"Divisible"<<endl;
        else cout<<"Not divisible"<<endl;
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.