现在的位置: 首页 > 综合 > 正文

POJ 2376

2019年04月04日 ⁄ 综合 ⁄ 共 2089字 ⁄ 字号 评论关闭

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and
the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow
to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

</pre><pre name="code" class="html">思路:典型的区间覆盖问题; 不过要特别注意对该题区间的的理解,该题每个区间都是闭合的,且左右可以相等;
</pre><pre name="code" class="html">
</pre><pre name="code" class="html">
</pre><pre name="code" class="html">#include <algorithm>
#include <iostream>
#include <cstring>
#include <climits>
#include <cstdio>
#include <string>
#include <vector>
#include <cmath>
#include <cctype>
#include <deque>
#include <queue>
#include <list>
#include <map>
#include <set>
using namespace std;

const int maxn=25000 + 10;
struct Lamb{
int a,b;
bool operator < (const Lamb& rhs) const{
return a<rhs.a ;
}
}lamb[maxn];
int n,t;
int main()
{
        cin>>n>>t;
        for(int i=0;i<n;i++) cin>>lamb[i].a>>lamb[i].b;
        sort(lamb,lamb+n);
        int key=0,max,fff=1,num=0;
        for(int i=0;i<n;i++)
        {
            if(lamb[i].a>key+1) {fff=0; break;}
            max=lamb[i].a;
            int j;
            for( j=i;j<n;j++)
            {
                if(lamb[j].a>key+1) break;
                max= max > lamb[j].b ? max : lamb[j].b;
            }
            key=max;
            num++;
            i=j-1;
            if(j==n||key>=t) break;
        }
        if(fff&&key>=t) cout<<num<<endl;
        else cout<<"-1\n";
        return 0;
}

抱歉!评论已关闭.