现在的位置: 首页 > 综合 > 正文

POJ3140 简单树形DP

2019年08月21日 ⁄ 综合 ⁄ 共 2453字 ⁄ 字号 评论关闭
Contestants Division
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8119   Accepted: 2318

Description

In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee
can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between
the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?

Input

There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the
committee, respectively. Universities are numbered from 1 to N. The next line has N integers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university
does not exceed 100000000. Each of the following M lines has two integers st, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.

N = 0, M = 0 indicates the end of input and should not be processed by your program.

Output

For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.

Sample Input

7 6
1 1 1 1 1 1 1
1 2
2 7
3 7
4 6
6 2
5 7
0 0

Sample Output

Case 1: 1

题意:

一棵树,每个节点有权值,求去掉一条边,使得两颗子树的权值差最小!

分析:

话说DP的本质就是-----记忆化搜索。

这题就是DFS下 以每个节点为根的子树权值和!

因为整棵树值是知道的。。

权值之差就是  sum-2*dp[i]

遍历一遍所有节点就OK!

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100005
#define M 1000005
#define LL long long
int head[N];
struct edge
{
    int v,next;
}e[M];
int t;
LL v[N];
LL dp[N];
bool used[N];
void init()
{
    memset(head,-1,sizeof(head));
    memset(used,0,sizeof(used));
    memset(dp,0,sizeof(dp));
    t=0;
}
void add(int x,int y)
{
    e[t].v=x;
    e[t].next=head[y];
    head[y]=t++;
    e[t].v=y;
    e[t].next=head[x];
    head[x]=t++;
}
void dfs(int u)
{
    used[u] = true;
    dp[u] = v[u];
    for(int i=head[u];i>=0;i=e[i].next)
    {
        if(!used[ e[i].v ] )
        {
            dfs( e[i].v );
            dp[u]+=dp[ e[i].v ];
        }
    }
}
LL abs( LL x )
{
    return x<0?-x:x;
}
LL min(LL x ,LL y)
{
    return x>y?y:x;
}
int main()
{
    int n,m,i,j,k,icase=1;
    while(~scanf("%d%d",&n,&m) && (n||m)  )
    {
        init();
        LL all=0;
        LL ans;
        for(i=1;i<=n;i++)
        {
            scanf("%I64d",&v[i]);
            all+=v[i];
        }
        while(m--)
        {
            scanf("%d%d",&j,&k);
            add(j,k);
        }
        dfs(1);
        printf("Case %d: ",icase++);
        ans=abs(all-2*dp[1]);
        for(i=2;i<=n;i++)
        ans=min(ans,abs(all-2*dp[i]));
        printf("%I64d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.