现在的位置: 首页 > 综合 > 正文

POJ1463 简单树形DP

2019年08月21日 ⁄ 综合 ⁄ 共 2047字 ⁄ 字号 评论关闭
Strategic game
Time Limit: 2000MS   Memory Limit: 10000K
Total Submissions: 6260   Accepted: 2883

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the
minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 



the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 
  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1

2

题意:

在树上的节点上放尽量少的士兵,监视所有的节点。。

分析:类似01背包,该节点只有 放或不放 士兵的两种选择!

状态:

dp[i][0] 表示以i为根节点,i不放士兵最优值。

dp[i][1] 表示以i为根节点,i放士兵的最优值。

状态转移方程

dp[i][0]=Σ dp[j][1] j为i子节点

dp[i][1]=Σ min(dp[j][1],dp[j][0])

边界:

全部节点初始化

dp[i][0] = 0;

dp[i][1]= 1;

    #include <stdio.h>
    #include <vector>
    using namespace std;

    #define INF 99999999

    vector <int> edge[2005];
    int dp[2005][2];
    int n;

    void DFS(int t,int p)
    {
        int i,k;
        if (edge[t].size()==1 && p!=-1)
        {
            dp[t][0]=0;
            dp[t][1]=1;
            return;
        }
        dp[t][0]=dp[t][1]=0;
        for (i=0;i<edge[t].size();i++)
        {
            k=edge[t][i];
            if (k==p) continue;
            DFS(k,t);
            dp[t][0]+=dp[k][1];
            dp[t][1]+=min(dp[k][0],dp[k][1]);
        }
        dp[t][1]++;
    }

    int main()
    {
        int i,j,x,y,k;
        while(scanf("%d",&n)!=EOF)
        {
            for (i=0;i<n;i++)
            {
                edge[i].clear();
            }
            for (i=0;i<n;i++)
            {
                scanf("%d:(%d)",&x,&k);
                while(k--)
                {
                    scanf("%d",&y);
                    edge[x].push_back(y);
                    edge[y].push_back(x);
                }
            }
            DFS(0,-1);
            printf("%d\n",min(dp[0][0],dp[0][1]));
        }
        return 0;
    }

抱歉!评论已关闭.