现在的位置: 首页 > 综合 > 正文

HDU1724 – 积分

2019年08月21日 ⁄ 综合 ⁄ 共 1271字 ⁄ 字号 评论关闭

Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 876    Accepted Submission(s): 280


Problem Description
Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:

A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task
is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )

 


Input
Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation ,
A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).
 


Output
For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.
 


Sample Input
2 2 1 -2 2 2 1 0 2
 


Sample Output
6.283 3.142
 


Author
威士忌
 


Source
简单高数题.
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
double a,b,l,r;
double f(double x)
{
	double t=asin(x/a);
	return 0.5*a*b*(t+0.5*sin(2*t));
}
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		cin>>a>>b>>l>>r;
		printf("%.3lf\n",2*(f(r)-f(l)));
	}
	return 0;
}

抱歉!评论已关闭.