现在的位置: 首页 > 综合 > 正文

ZOJ1825-二分寻找子串

2019年08月21日 ⁄ 综合 ⁄ 共 873字 ⁄ 字号 评论关闭

Compound Words


Time Limit: 5 Seconds      Memory Limit: 32768 KB


You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn

掌握一个二分寻找 子串的方法!

#include<algorithm>
#include<iostream>
#include<string>
using namespace std;
string word[120000];
int main()
{
	int i=0;
	while(cin>>word[i++]);
	for(int j=0;j<i;j++)
	{
		for(int k=0;k<word[j].size();k++)
		{
			if(binary_search(word,word+i,word[j].substr(0,k)))  //记住这个 二分的模板.
			{
				if(binary_search(word,word+i,word[j].substr(k))) //(数组指针,需要排序到的数组尾部,需要查找的key)
				{
					cout<<word[j]<<endl;
				break;
				}
			}
		}
	}
	return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.