现在的位置: 首页 > 综合 > 正文

robot motion

2013年04月21日 ⁄ 综合 ⁄ 共 2689字 ⁄ 字号 评论关闭
文章目录

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1890    Accepted Submission(s): 865

Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0

Sample Output

10 step(s) to exit 3 step(s) before a loop of 8 step(s)

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int n,m,k;
char map[100][100];
int mark[110][110],ans;
void DFS(int i,int j)
{
 if(i<=0||j<=0||i>n||j>m)
 {
   printf("%d step(s) to exit\n",ans);
   return ;
 }
 else if(mark[i][j]!=0)
 {
  printf("%d step(s) before a loop of %d step(s)\n",mark[i][j]-1,ans-mark[i][j]+1);
 }
 else 
    {
    if(map[i][j]=='S')
     {
     ans++;
     mark[i][j]=ans;
     DFS(i+1,j);
     }
   else if(map[i][j]=='N')
     {
     ans++;
     mark[i][j]=ans;
     DFS(i-1,j);
     }
   else if(map[i][j]=='W')
     {
     ans++;
     mark[i][j]=ans;
     DFS(i,j-1);
     }
  else if(map[i][j]=='E')
     {
     ans++;
     mark[i][j]=ans;
     DFS(i,j+1);
     }
 }
     
}
int main( )
{
    
   while(scanf("%d%d%d",&n,&m,&k),n||m)
   {
    int i,j;
    char c;
    getchar();
    for(i=1;i<=n;i++)
      {
      for(j=1;j<=m;j++)
        {
         scanf("%c",&c);
         
         map[i][j]=c;
        // printf("%c ",map[i][j]);
        }
      getchar();
      }
      ans=0;
   memset(mark,0,sizeof(mark));
   DFS(1,k);
  }
   return 0;
}
  这道题刚开始做时,思路错了,后来搜了下,才幡然大悟,感觉搜索真的很强大。
在输入数据时要注意下,是scanf(“%c”,&c);需要吸收回车键。。
dfs个人感觉思路,主要是建图,然后如何控制dfs结束。把这两个问题解决好了,就基本上
可以解决问题了。
      
         

抱歉!评论已关闭.