现在的位置: 首页 > 综合 > 正文

poj 1979 搜索

2013年04月12日 ⁄ 综合 ⁄ 共 1968字 ⁄ 字号 评论关闭
Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 19263   Accepted: 10259

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

这是一道简单的dfs,我手残在忘记把文件输入的语句 给注释了,结果就跪了。
下面是代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>

using namespace std;

int dir[8][2]={{-1,0},{0,1},{1,0},{0,-1}};
int w,h,ans;
char map[30][30];

void dfs(int x,int y){
     if(x<0||x>=h||y<0||y>=w)
         return;
      for(int i=0;i!=4;++i){
          int xx=x+dir[i][0];
          int yy=y+dir[i][1];
          if(map[xx][yy]=='.'){
              map[xx][yy]='1';
              dfs(xx,yy);
          }
      }
      return;
}

int main(){
     //freopen("input.txt","r",stdin);
    // freopen("output.txt","w",stdout);
     int sx,sy;
    while(scanf("%d%d",&w,&h)!=EOF&&w&&h){
         for(int i=0;i!=h;++i){
             scanf("%s",map[i]);
             for(int j=0;j!=w;++j){
                   if(map[i][j]=='@'){
                         sx=i;
                         sy=j;
                   }
             }
         }
         map[sx][sy]='1';
         ans=0;
         dfs(sx,sy);
         for(int i=0;i!=h;++i)
            for(int j=0;j!=w;++j){
                if(map[i][j]=='1')
                    ++ans;
            }
          cout<<ans<<endl;
    }
}

抱歉!评论已关闭.