现在的位置: 首页 > 综合 > 正文

HDU 2899 Strange fuction 二分求方程解

2018年01月20日 ⁄ 综合 ⁄ 共 1086字 ⁄ 字号 评论关闭

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3242    Accepted Submission(s): 2371

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2 100 200
Sample Output
-74.4291 -178.8534
/*
hdoj 2199
求解方程 虽然函数不具有单调性
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x
但是其导数具有单调性 求函数的最小值 
F’(x) = 42 * x^6+48*x^5+21*x^2+10*x-y
即导数为0的时候 
*/

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;

double y;

double fun(double x){
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}

double fun1(double x)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}

double find()
{
    double mid,a=0,b=100;
    while(b-a>1e-6)
    {
        mid=(a+b)/2;
        if(0>fun(mid))
            a=mid+1e-7;
        else 
            b=mid-1e-7;
    }
    return fun1(mid);
}

int main()
{
    int n;
    
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf",&y);
        
        printf("%.4lf\n",find());
            
    }
    return 0;
}

抱歉!评论已关闭.