现在的位置: 首页 > 综合 > 正文

hdu 2602 Bone Collector

2018年01月20日 ⁄ 综合 ⁄ 共 1996字 ⁄ 字号 评论关闭

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30095    Accepted Submission(s): 12389

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
/*题解:(对01背包问题的个人理解)       01背包问题,0代表不放,1代表放,即是对第i个物品放或者不放的背包问题。      01背包问题通常具有以下特征:         1.物品有很多种,但是每种仅有一个         2.背包容量有限,题目要求得到最优解         3.通过递推的方式,可以求得最优解  */
#include<cstdio>
#include<cstring>
int dp[1010][1010];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int T,n,v,i,j,w[1010],val[1010];
    scanf("%d",&T);
    while(T--)
	{
        memset(dp,0,sizeof(dp));
        scanf("%d %d",&n,&v);
        for(i=1; i<=n; i++)
            scanf("%d",&val[i]);
        for(i=1; i<=n; i++)
            scanf("%d",&w[i]);
        for(i=1; i<=n; i++)
		{
            for(j=0; j<=v; j++)
			{
                if(j>=w[i])
				{        //放还是不放 
                     dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+val[i]);
                }
                else
                    dp[i][j]=dp[i-1][j];
            }
        }
        printf("%d\n",dp[n][v]);
    }
    return 0;
}

/*题解:
    滚动数组(一维数组),解01背包问题。
    参考自《算法竞赛入门经典第二版》p273 
*/
#include<cstdio>
#include<cstring>
int dp[1010];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int T,n,v,i,j,w[1010],val[1010];
    scanf("%d",&T);
    while(T--)
	{
        memset(dp,0,sizeof(dp));
        scanf("%d %d",&n,&v);
        for(i=1; i<=n; i++)
            scanf("%d",&val[i]);
        for(i=1; i<=n; i++)
            scanf("%d",&w[i]);
        for(i=1; i<=n; i++)
		{
            for(j=v; j>=0; j--)
			{
                    if(j>=w[i]) dp[j]=max(dp[j],dp[j-w[i]]+val[i]);
            }
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}                
                 

抱歉!评论已关闭.