现在的位置: 首页 > 综合 > 正文

hdu 1163 Eddy’s digital Roots

2018年05月02日 ⁄ 综合 ⁄ 共 1372字 ⁄ 字号 评论关闭

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4646    Accepted Submission(s): 2590

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.

 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n's digital root on a separate line of the output.
 

Sample Input
2 4 0
 

Sample Output
4 4
 

/*题解: 
运用九余数定理 
*/
九余数定理:
一个数的树根(一个数各位数之和直到该数为1位数)得到的那个数等于该数对9的余数
例如:12的树根为3,178的树根为7
根据九余数定理:root(12)=12%9  root(178)=178%9 

#include<cstdio>
int main()
{
    int n,i,s,t;
    while(scanf("%d",&n)&&n)
    {
        for(i=1,s=1; i<=n; i++)
        {
            s*=n;
            s%=9;
        }
        if(s==0)
            printf("9\n"); 
        else if(s<9)
            printf("%d\n",s);
        else
        {
            t=0;
            while(t<10)
            {
                t+=s%10;
                s/=10;
            }
            printf("%d\n",t);
        }
    }
    return 0;
}

抱歉!评论已关闭.