现在的位置: 首页 > 综合 > 正文

Hdu 2639 Bone Collector II

2018年01月15日 ⁄ 综合 ⁄ 共 1846字 ⁄ 字号 评论关闭

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 921    Accepted Submission(s): 440

题目链接

Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a
link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum
.. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

 


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value
of each bone. The third line contain N integers representing the volume of each bone.
 


Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 


Sample Input
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 


Sample Output
12 2 0
 


Author
teddy
 


Source
 

Recommend
teddy

求01背包的第k大解。

#include<stdio.h>
#include<string.h>

int w[101],v[101];
int a[31],b[31];
int dp[1001][31];

int main(void)
{
	int T,N,V,K,i,j,m,n_a,n_b,n_c;
//	freopen("d:\\in.txt","r",stdin);
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&N,&V,&K);
		for(i=1;i<=N;i++)
			scanf("%d",&v[i]);
		for(i=1;i<=N;i++)
			scanf("%d",&w[i]);
		memset(dp,0,sizeof(dp));
		for(i=1;i<=N;i++)
			for(j=V;j>=w[i];j--)
			{
				for(m=1;m<=K;m++)
					a[m]=dp[j-w[i]][m]+v[i];
				for(m=1;m<=K;m++)
					b[m]=dp[j][m];
				a[m]=b[m]=-1;
				n_a=n_b=n_c=1;
				while(n_c<=K && (n_a<= K || n_b<=K))
				{
					if(a[n_a]>=b[n_b])
						dp[j][n_c]=a[n_a++];
					else
						dp[j][n_c]=b[n_b++];
					if(dp[j][n_c]!=dp[j][n_c-1])
						n_c++;
				}
			}
		printf("%d\n",dp[V][K]);
	}
	return 0;
}
 

【上篇】
【下篇】

抱歉!评论已关闭.